読者です 読者をやめる 読者になる 読者になる

by shigemk2

当面は技術的なことしか書かない

Fluentd沼 Error installing fluentd

Fluentd

0.12.22あたりでgem install fluentdなどすると、string-scrub関係でFluentdがインストール出来ない。

# gem install fluentd -v 0.12.22
ERROR:  Error installing fluentd:
    string-scrub requires Ruby version <= 2.0.0, >= 1.9.3.
  • Fluentdのバージョンを上げましょう、という話。
  • recentとか曖昧な言葉を使うのはやめましょう、という話。

github.com