読者です 読者をやめる 読者になる 読者になる

by shigemk2

当面は技術的なことしか書かない

ECONFLICT Unable to find suitable version for angular

JavaScript

github.com

angular関係でちゃんとバージョンを指定していなかったら怒られるパターン。

怒られるパターン。

{
  "name": "project",
  "version": "0.0.1",
  "devDependencies": {
    "angular": "~1.2.0-rc.2",
    "angular-mocks": "~1.2.0-rc.2",
    "bootstrap": "~2.3.2",
    "angular-bootstrap": "~0.5.0",
    "angular-ui-router": "~0.0.1",
    "angular-ui-utils": "~0.0.4",
    "angular-sanitize": "~1.2.0-rc.2",
    "angular-resource": "~1.2.0-rc.2",
    "angularytics":"0.2.2",
      "json2":"*",
    "underscore":"1.5.1",
    "restangular":"1.1.3",
    "tinymce": "git://github.com/jozzhart/tinymce.git#4.0.0"
  },
  "dependencies": {}
}

OKなパターン。

{
  "name": "project",
  "dependencies": {
    "angular-resource": "xxxx",
    ....
  },
  "resolutions": {
    "angular": "xxxxx"
  }
}