読者です 読者をやめる 読者になる 読者になる

by shigemk2

当面は技術的なことしか書かない

tscの-tオプションとエラー error TS1056: Accessors are only available when targeting ECMAScript 5 and higher.

TypeScript

tscでTypeScriptをコンパイルするとこんなエラーが出ることがある。

error TS1056: Accessors are only available when targeting ECMAScript 5 and higher.

accessor.ts

で、tscのオプションでEcmaScriptのバージョンを指定するオプションがある。

-t VERSION, --target VERSION      Specify ECMAScript target version: 'ES3' (default), 'ES5', or 'ES6' (experimental)

これでバージョンを指定してコンパイルするとうまくいく。

$ tsc -t ES5 accessor.ts