読者です 読者をやめる 読者になる 読者になる

by shigemk2

当面は技術的なことしか書かない

The `' command exists in these Ruby versions状態で、いつまでたっても ~/.rbenv/shims/ の下にスクリプトが残ったままになる

rbenv

いつまでたっても起動スクリプトが~/.rbenv/shims に残ったままになっていて
gitエイリアスでhubコマンドを実行しようにも

rbenv: hub: command not found

The `hub' command exists in these Ruby versions:
  1.9.3-p392

こういう状態になってしまう。

rbenvでuninstallしたはずのgemに対するスクリプトが~/.rbenv/shimsに残り続けててハマった - F.Ko-Jiの「一秒後は未来」

それぞれのバージョンのgemにhubが入っていたかもだから
(というかエラーメッセージをちゃんと読んだらそう書いてある)

そのバージョンのgemパッケージをuninstallしたらよい。